Routing issue for some ISP's
Incident Report for clustered.net
Resolved
We believe the routing issues are now resolved. If you still have problems please raise a support ticket.
Posted Feb 12, 2022 - 15:21 UTC
Investigating
We are still seeing issues routing back to Virgin and some European ISP's. Engineers are investigating.
Posted Feb 12, 2022 - 12:58 UTC
This incident affected: Networks.